Intermittent iTimekeep Performance Issues

Incident Report for Aderant Cloud Platform

Resolved

Normal performance has been restored.
Posted Dec 01, 2025 - 13:42 EST

Monitoring

System logs, telemetry, and live checks show the environment running as expected and performing within normal thresholds. We continue to monitor the while our teams investigate root cause.
Posted Dec 01, 2025 - 11:54 EST

Investigating

We are currently investigating intermittent iTimekeep performance issues.
Posted Dec 01, 2025 - 10:39 EST
This incident affected: iTimekeep (iTimekeep US).