Intermittent iTimekeep Latency Issues

Incident Report for Aderant Cloud Platform

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 12:47 EDT

Investigating

We are currently investigating intermittent latency for some users.
Posted Jun 01, 2026 - 11:57 EDT
This incident affected: iTimekeep (iTimekeep US).