To address an underlying Microsoft issue, we will be taking an emergency outage tonight from 9:00 PM EDT / 6:00 PM PDT for approximately 15–20 minutes. During this time, iTimekeep will be inaccessible. Service will be restored immediately once the work is complete. We appreciate your patience and understanding as we work to resolve this issue as quickly as possible.
Posted Jul 21, 2026 - 19:59 EDT
Identified
Working closely with Microsoft, we have identified the source of the issue and a fix is now being implemented. We are actively monitoring progress and will continue to keep you updated as we move toward resolution. Thank you for your patience and partnership.
Posted Jul 21, 2026 - 18:06 EDT
Update
Our teams remain fully engaged on the performance issues affecting iTimekeep. This is our top priority and work is ongoing.
What you may see: slower than normal response times, and in some cases an action may fail. If an action does not complete, we recommend avoiding repeated retries of the same action to minimize the risk of duplicate entries or other issues.
We understand the impact this has on capturing your time and we are working to restore normal performance as quickly as we safely can.
Posted Jul 21, 2026 - 16:33 EDT
Update
We are still working to resolve the performance issues affecting iTimekeep, and this remains our team's top priority.
Response times are slower than normal, and some actions may fail and need to be retried. We are focused on restoring normal performance as quickly as we safely can.
Posted Jul 21, 2026 - 14:27 EDT
Update
Our teams are continuing to actively investigate the increased latency affecting iTimekeep. You may continue to experience slower than normal response times while we work on this.
We apologize for the continued inconvenience and will provide a further update as soon as we have more information.
Posted Jul 21, 2026 - 12:21 EDT
Investigating
We are aware of increased latency affecting iTimekeep and some users may experience slower than normal response times. Our team is actively investigating and working to resolve the issue as quickly as possible.
We apologize for the inconvenience and will provide an update as soon as we have more information