iTimekeep - Performance Degradation

Incident Report for Aderant Cloud Platform

Resolved

The maintenance work to address the latency affecting iTimekeep is complete, and iTimekeep is available for normal use. We are seeing improved performance and will continue to monitor closely to ensure it holds. A root cause analysis is ongoing and will be shared once complete. Thank you for your patience throughout.
Posted Jul 22, 2026 - 17:00 EDT

Update

iTimekeep - Scheduled Outage

Please note a change in timeframe for the planned outage:

We apologize for the continued disruption, and we appreciate your patience as we work to resolve it. We will be applying a change to improve the experience during a planned outage from 4:15 PM to 5:15 PM EDT. iTimekeep will be inaccessible during this time

Please share this information with your timekeepers so they are aware iTimekeep will be unavailable during the timeframe below.

Outage: iTimekeep will be inaccessible from 4:15 PM to 5:15 PM EDT.
Impact:
No customer impact or UI changes.
No customer action is required.
We recommend timekeepers save any in-progress work before 4:15 PM EDT.

We will confirm here once service is restored.
Posted Jul 22, 2026 - 16:00 EDT

Identified

iTimekeep - Scheduled Outage

We apologize for the continued disruption, and we appreciate your patience as we work to resolve it. We will be applying a change to improve the experience during a planned outage from 4:15 PM to 6:15 PM EDT. iTimekeep will be inaccessible during this time

Please share this information with your timekeepers so they are aware iTimekeep will be unavailable during the timeframe below.

Outage: iTimekeep will be inaccessible from 4:15 PM to 6:15 PM EDT.
Impact:
No customer impact or UI changes.
No customer action is required.
We recommend timekeepers save any in-progress work before 4:15 PM EDT.

We will confirm here once service is restored.
Posted Jul 22, 2026 - 15:45 EDT

Update

Our teams are continuing to test a potential resolution for the latency affecting iTimekeep. We will share more specific detail, including any planned maintenance, once we are able to. Performance remains stable but elevated above normal.
Posted Jul 22, 2026 - 15:24 EDT

Update

Our teams remain engaged with Microsoft on the latency affecting iTimekeep. We are evaluating a potential resolution path and testing it before any broader application. Performance remains stable but elevated above normal.
Posted Jul 22, 2026 - 14:17 EDT

Update

Our teams remain engaged with Microsoft on the latency. Investigation continues on multiple fronts simultaneously. Root cause has not yet been identified. Performance remains stable but elevated above normal.
Posted Jul 22, 2026 - 12:58 EDT

Update

Our teams remain engaged with Microsoft to address the latency. A subset of instances is experiencing higher than normal response times. Latency has stabilized and is running below yesterday's peak, though it remains elevated. Investigation continues and further updates will be posted here.
Posted Jul 22, 2026 - 11:59 EDT

Update

Our teams are continuing to investigate the performance degradation, working alongside Microsoft toward resolution.
Posted Jul 22, 2026 - 11:04 EDT

Investigating

The performance degradation affecting iTimekeep yesterday persists and is being investigated further with Microsoft for resolution.
Posted Jul 22, 2026 - 09:52 EDT
This incident affected: iTimekeep (iTimekeep US).