Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 06, 2024 - 22:00 EST
Scheduled
On Wednesday (Nov-6) iTimekeep US and CAN regions will undergo scheduled updates between 10pm-11pm EST / 3am UTC. There will be no expected downtime during the maintenance period.
Users may need to clear cookies/caches to consume update once complete. This release does not include a mobile update or any changes to Connect.
This update will include the following:
IMPROVEMENTS
• Extending logging capabilities surrounding the reporting services. • Within the Dashboard and Calendar views: Accountable Time displays in the appropriate time category based on subscription settings (NOTE: Where Accountable Time is supported).
When Accountable Time is turned OFF, any timecards with accountable time matter is added to non-billable hours. When Accountable Time is turned ON, accountable time timecards will be in accountable time, non-billable timecards will be in non-billable.
FIXES
• In the Dashboard view: Addressed an issue where Accountable Time was not included in the Missing Time calculation.
Posted Nov 04, 2024 - 15:52 EST
This scheduled maintenance affected: iTimekeep (iTimekeep US, iTimekeep CAN).