Onyx Update – US, CAN, UK, EU and APA

Scheduled for Mar 10, 07:00 - 09:00 EDT

Scheduled

On Tuesday, March 10, 2026, Onyx systems in the US, Canada, UK, EU, and APA regions will undergo scheduled updates between 7:00 AM – 9:00 AM EDT / 11:00 AM – 1:00 PM UTC.

No downtime is expected during this maintenance window.

Bug Fixes

- Location field Validation (iTimekeep):
Resolved an issue where time entry rules using the Location field could not be validated. The field expression @entry.tkLocation has been added to the Advanced mode rule builder and can now be used to access the Location field for time entries from iTimekeep.

- Violations Report:
Removed the Rule Set column from the report as it was displaying inconsistent data.

Resolved an inconsistency in the Report Summary where records containing both a Warning and an Error were not being accurately reflected in the summary buckets. Records will now correctly count toward both the Warning and Error totals when applicable.

Performance Improvements

- Improved system performance and stability when validating large volumes of data.
Posted Mar 03, 2026 - 09:45 EST
This scheduled maintenance affects: Onyx (Onyx US, Onyx CAN, Onyx UK, Onyx APA, Onyx EU).