BillBlast Partial Outage

Incident Report for Aderant Cloud Platform

Resolved

The issue previously impacting some BillBlast functionality has now been resolved.
Posted Mar 30, 2026 - 12:42 EDT

Investigating

We have identified an issue impacting some BillBlast functionality.

Our teams are investigating and will provide an update as soon as more information becomes available.

In the meantime, you may experience unexpected "failure messages" or delays/interruptions in service.

Please monitor the myAderant Support Portal or the Status Page for updates

Thank you,
BillBlast Suport Team
Posted Mar 30, 2026 - 11:53 EDT
This incident affected: BillBlast (BillBlast US, BillBlast CAN, BillBlast UK, BillBlast APA).