Microsoft Azure Networking Issue (West US Region)

Incident Report for Aderant Cloud Platform

Resolved

Microsoft has confirmed resolution of the Azure West US networking issue, and performance across all affected services has returned to normal and remained stable. We are considering this issue resolved.

Thank you for your patience throughout. A root cause analysis from Microsoft is expected to follow, and we will share relevant detail once available.

Microsoft's regional status is available at https://azure.status.microsoft/en-us/status.
Posted Jul 23, 2026 - 17:06 EDT

Update

Performance across affected services has remained stable, and we are seeing close to normal operation. Microsoft's rollback of the correlated change appears to have taken effect.

We are holding this in a monitoring state pending Microsoft's final resolution confirmation, and remain in contact with them. We will post a final update once Microsoft confirms full resolution.

Microsoft's regional status is available at https://azure.status.microsoft/en-us/status.
Posted Jul 23, 2026 - 16:10 EDT

Update

Microsoft has identified a recent change strongly correlated with the onset of this issue and has begun rolling it back. That rollback is in progress, and early telemetry is showing signs of recovery. We are independently seeing improved performance and stability across affected services.

This is not yet confirmed as resolved. Microsoft has not declared full recovery, and we are continuing to monitor closely alongside them until they do. We will update as the situation develops.

Microsoft's regional status is available at https://azure.status.microsoft/en-us/status.
Posted Jul 23, 2026 - 15:00 EDT

Update

Correction to our previous update: the prior message associated with the status change to "Monitoring" was posted in error. No fix has been implemented, and this issue is not resolved.

This is a Microsoft Azure networking issue in the West US region, which Microsoft has classified as critical. Resolution is on Microsoft's side and there is no corrective action available on our end. We are, however, in direct communication with the Microsoft team. Microsoft's mitigation attempts so far have not produced broad improvement, and no ETA is available. We will update as the situation changes.

Microsoft's regional status is available at https://azure.status.microsoft/en-us/status.
Posted Jul 23, 2026 - 14:02 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 13:16 EDT

Investigating

Microsoft has reported a networking issue affecting the Azure West US region, which is impacting some of our services. Per Microsoft, affected customers may experience intermittent connectivity failures, increased latency, or difficulty accessing services in that region. Microsoft has begun applying mitigations. We are engaged with them and monitoring closely. Further updates will be posted here, and Microsoft's status is available at https://azure.status.microsoft/en-us/status.
Posted Jul 23, 2026 - 13:01 EDT
This incident affected: iTimekeep (iTimekeep US).